IT/Lab Admin Support

Many of the most common questions are described below. If you don't find what you're looking for, our 24/7 Technical Support team is ready to help.

Search our Online Knowledge Base for answers to a comprehensive set of questions. The Knowledge Base lets you search by category, keywords, or phrases. You can even subscribe to articles to receive email notifications when they are updated.

Basic requirements for all MyLab Math courses

  • Internet connection: Cable/DSL, T1, or other high-speed for multimedia content; 56k modem (minimum) for tutorials, homework, and testing.
  • Memory: 64 MB RAM minimum
  • Monitor resolution: 1024 x 768 or higher
  • Plug-ins: You need certain plug-ins and players from the MyLab Math Browser Check or Installation Wizard (found inside your course). See below for more information.

System Requirements and Browser Check

To complete online assignments in MyLab Math, students sign into their course through a supported web browser. In order to view and complete assignments in MyLab Math, users must work within the MathXL Player, a Flash-based tool that displays algorithmic math exercises and allows students to enter math notation in their answers.

Lab administrators and IT staff can use the Browser Check/Installation Wizard below to install components for all MyLab Math courses taught in the lab. The Browser Check is configured to install only the plug-ins and players needed for an individual course (based on the textbook used). Note that it's advisable to check and reinstall components before the beginning of each semester.

Tip: If you are setting up a lab for students using several MyLab Math courses, choose the "Administrators" option at the bottom of the list to conveniently access and install components.

Note that in some courses, the Browser Check may be referred to as the Installation Wizard. Clicking the Installation Wizard link will open the Browser Check.

Run the Installation Wizard / Browser Check

*Students do not need the absolute latest version of the Flash player to use the eText. They need only version 10.2 or higher, which they can download from Adobe’s website.

Lab Administrator Resources

For information on setting up lab computers to use Pearson players and other plug-ins, see Player Installation for Computer Lab Administrators.

TOP