System Requirements

Please make sure that your computer meets all of the requirements detailed below.

Note that you may need administrative access to be able to install applications or make other changes to your computer. If the computer you are using is not your own personal property, you may need to contact your organization's IT department to make such updates.

Operating Systems and Browsers

Don't know your operating system version? Here's how to find it: Windows | Mac

Don't know your browser version? Find out here

To download the latest versions of these browsers, visit their websites:
Chrome     Edge     Firefox     Internet Explorer     Safari

  Operating systems browsers

Windows

Windows 10

Edge 12 or newer
Firefox 49 or newer
Chrome 53 or newer

 

Windows 7, 8, and 8.1

Internet Explorer 11
Firefox 49 or newer
Chrome 53 or newer

Mac OS

OS X 10.12 - Sierra

Safari 10
Firefox 49 or newer
Chrome 53 or newer

  OS X 10.11 - El Capitan

Safari 9 or newer
Firefox 49 or newer
Chrome 53 or newer

  OS X 10.10 - Yosemite

Safari 8 or newer
Firefox 49 or newer
Chrome 53 or newer

  OS X 10.9 - Mavericks

Safari 7 or newer
Firefox 49 or newer
Chrome 53 or newer

Players and Plug-ins

You may receive a message that some Mastering assignment content cannot be displayed because it requires a browser player or plug-in. Click the player or plug-in name below to download the latest version. If the browser you’re using no longer supports such players or plug-ins (like recent versions of Chrome or Firefox), please use another supported browser for this content.

These players and plug-ins may have their own system requirements, which can be found on their websites. In some cases, you may need to register for the player or plug-in, and you may need to restart your computer when you finish the download and installation.

Mobile Devices

Mobile Browser Requirements

After you sign in to your Mastering course on a computer at least once, you have the option to use a smartphone or tablet to work on Mastering assignments, Learning Catalytics sessions, and Dynamic Study Modules. (Educators, a student account is needed to work in Mastering standard’s Mobile view.) Note that you may need to return to your computer to complete some assignments or assignment items. Supported browsers are listed below. The Kindle is not supported.

  Browsers

Android*

Google Chrome 53 or newer

iOS

Safari 9 (iOS 9 or newer)
Google Chrome 53 or newer

* The native Android browser is not supported.

Mobile Apps

The following optional, free mobile apps are available for your convenience.

  • Pearson eText app (tablets) or eText 2.0 app (smartphones and tablets)
    The app you need depends on whether your book is in eText or eText 2.0 format. Top navigation is dark blue for eText, black for eText 2.0. Before you can use the eText app, you must first open your eText at least once from your Mastering course. (This action is not required for the eText 2.0 app.)
  • App to work on Dynamic Study Modules on smartphones and iPod touch
    This app optimizes your Dynamic Study Modules experience on a mobile device. If your Mastering course has the Dynamic Study Modules link on its Course Home page and you have clicked this link at least once on your computer to open a module, you can use the Dynamic Study Modules app on your iOS or Android smartphone. (This app is not supported on tablets or for MasteringPlus users.)
    Tablet users: You can work on any available Dynamic Study Modules after you sign in to your course.

Other Requirements

Requirements for Editing and Creating Content (for Educators only)

The Simple Editor and the Advanced Editor (also known as the Authoring Tool) enable you to produce custom assignable items.

Simple Editor

Requirements for the Simple Editor match the latest operating systems and browsers for Mastering (above). To access all features of the Simple Editor, set your browser security to allow pop-ups.

Advanced Editor

The requirements for the Advanced Editor are more restrictive than for either Mastering or the Simple Editor.

  Operating Systems Browsers 

Windows

Windows 7 Internet Explorer 9.x

Mac OS

You need a Windows emulator. Internet Explorer 9.x

Important information about working with Internet Explorer 9: Regardless of your operating system, you should use Internet Explorer 9 to work with the Advanced Editor. (Internet 10 Desktop is not yet fully supported for authoring.) When downloading Internet Explorer 9, be sure to choose the 32-bit version (rather than the 64-bit version). After you have opened the Advanced Editor in 32-bit mode, it will automatically open in this mode every time after that.

TOP